kristinakwai
06.10.2021 21:10

Напишите программу на паскале, использую оператор выбора!

для двух положительных целых переменных d (номер дня) и m (номер месяца), введенных с клавиатуры, определить и вывести на экран знак зодиака, соответствующий введенной дате: «водолей» (20.1–18.2), «рыбы» (19.2–20.3), «овен» (21.3–19.4), «телец» (20.4–20.5), «близнецы» (21.5–21.6), «рак» (22.6–22.7), «лев» (23.7–22.8), «дева» (23.8–22.9), «весы» (23.9–22.10), «скорпион» (23.10–22.11), «стрелец» (23.11–21.12), «козерог» (22.12–19.1).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
hromovaalyona2
20.05.2020 19:36
1) hdd и ssd - диск с магнитными дисками и твердотельный диск
2) приведение к стандартному виду ячеек памяти диска
3) на 2 области: Область хранения файлов (содержимое книги) Каталог (оглавление книги) содержит имя файла и указание на номер начального сектора на диске, объем файла, дату и время его создания. 
4) бит
5) потому что когда файл пишется на диск - он может писаться в разных его концах. из-за этого для его считывания уходит много времени для перемещения головок
6) порядок, определяющий организации, хранения и именования данных на носителях информации в компьютерах, а также в другом электронном оборудовании
7) под файлом принято понимать ограниченный объём информации, существующей физически в ЭВМ, системе ЭВМ или сетях ЭВМ
8) дата создания, имя, размер 
9)
- имя файла и тип содержимого;
- дата и время создания файла;
- имя владельца файла;
- размер файла;
- права доступа к файлу;
- метод доступа к файлу.
10) 
Символ * - заменят любое количество символов
Символ ? - заменяет ровно один символ
11) 
Загрузочный сектор (Boot Record) 
Таблица размещения файлов(File Allocation Table — сокращенно FAT)
Корневой каталог (Root Directory) 
12) все что угодно
0,0(0 оценок)
Ответ:
лох248
08.12.2022 08:38

procedure p(x:integer; var st:string);

type

       name = array[0..9] of String[50];

     const

       s1 : name = (' ноль ',' один ',' два ',' три ',' четыре ',' пять ',' шесть ',' семь ',' восемь ',' девять ');

       s2: name = (' ',' десять ',' двадцать ',' тридцать ',' сорок ',' пятьдесят ',' шестьдесят ',' семьдесят ',' восемьдесят ',' девяносто ');

       s3: name = (' ',' сто ',' двести ',' триста ',' четыреста ',' пятьсот ',' шестьсот ',' семьсот ',' восемьсот ',' девятьсот ');

       s4 : name = (' ',' одиннадцать ',' двенадцать ',' тринадцать ',' четырнадцать ',' пятнадцать ',' шестнадцать ',' семнадцать ',' восемнадцать ',' девятнадцать ');

     var

       s,d,e : Integer;

begin

   s:= x div 100; x:=x mod 100;

   st:=s3[s];

   d:= x div 10; e:=x mod 10;

   if (d=1) and (e<>0) then st:=st+s4[e]

                        else st:=st+s2[d]+s1[e];

end;

var x:integer; st:string;

Begin

    Write('Введите число [0..100] :');

    Readln(x);

    p(x,st);

    writeln(st);

End.

Пример:

Введите число [0..100] : 12

дведнацать

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота