daulbaevazanel123
08.06.2020 03:21

Даны две дроби a b и c d

напишите программу, которая находит целую часть их суммы.

входные данные в первой строке указаны через пробел целые числа a, b, c и d

(1 6 a, b, c, d 6 100).

результат выведите целую часть суммы a

b + c=d
выразить в программу паскаль

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vkakochka
10.10.2020 06:08

Для начала решим это математически:

Пусть \frac{a}{b} и \frac{c}{d} - данные дроби.

Их сумма будет:

\frac{a}{b}+\frac{c}{d}=\frac{a*d+b*c}{b*d}

И нужно найти целую часть от деления (a*d+b*c) на (b*d).

Теперь составляем программу:

var a,b,c,d: integer;

begin

readln(a,b,c,d);

write(abs(a*d+b*c) div abs(b*d));

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота