ivandawidov
15.11.2022 13:41

Можете с в python? . створити список з випадкових цілих чисел. обчислити суму всіх чисел, кратних 5 та середнє арифметичне чисел, розміщених на непарних позиціях. сортувати список за зростанням і спаданням. ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
samuray99
30.01.2021 09:39
Задача 1.
var
  f:Text;
  n,nmax,nmin:integer;
begin
  Assign(f,'input.txt'); Reset(f);
  nmax:=-32786; nmin:=32767; {границы представления integer}
  while not Eof(f) do begin
    Readln(f,n);
    if (n>0) and (n mod 2=0) then
      if nmax<n then nmax:=n
      else
        if nmin>n then nmin:=n
  end;
  Close(f);
  Assign(f,'output.txt'); Rewrite(f);
  Writeln(f,nmin,' ',nmax);
  Close(f)
end.

Задача 2.
const
  m=100; { максимальное количество чисел в файле }
var
  f:Text;
  i,j,n,k:integer;
  a:array[1..m] of integer;
begin
  { читаем данные из файла в массив }
  Assign(f,'input.txt'); Reset(f);
  i:=0;
  while not Eof(f) do begin Inc(i); Readln(f,a[i]) end;
  Close(f);
  n:=i;
  { сортируем массив по возрастанию методом пузырька }
  for i := 1 to n-1 do
    for j := 1 to n-i do
      if a[j] > a[j+1] then
      begin k := a[j]; a[j] := a[j+1]; a[j+1] := k end;
  { заполняем файл из массива }
  Assign(f,'output.txt'); Rewrite(f);
  for i:=1 to n do Writeln(f,a[i]);
  Close(f)
end.

Вложение: пример файла input.txt
0,0(0 оценок)
Ответ:
mkalashnik1983
30.01.2021 09:39
{Напишите программу, которая находит минимальное и максимальное
среди чётных положительных чисел, записанных в файле,
и выводит результат в другой файл.}
var f:text;
  min, max,a :integer;
  find:boolean;{есть/нет числа удовлетворяющие условию}
begin
 assign(f,'dan.txt'); reset(f);
 min:=0; max:=0;
 find:=false;
 while not eof(f) do
 begin
  read(f,a);
  if not find and (a>0) and (a mod 2=0) then
  begin
   min:=a; find:=true;
  end
  else
  if find and (a>0) and (a mod 2=0) and (min>a) then
   min:=a;

  if (a>0) and (a mod 2=0) and (max<a) then
   max:=a;
 end;
 close(f);
 assign(f,'res.txt');
 rewrite(f);
 if max=0 then writeln(f,'чётных положительных чисел нет')
  else
   writeln(f,'min среди чётных положительных чисел =',min, chr(13),
      'max среди чётных положительных чисел нет',max);
  close(f);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота