Настька1210
20.04.2022 07:55

Составить программу, печатающую значение true, если указанное высказывание
является истинным, и false в противном случае: цифры данного трехзначного числа n являются членами прогрессии. программу надо написать на pascalabc. с пояснениями , только начинаю и вообще нечего не понимаю, надеюсь на понимание. заранее

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Yutik
19.05.2023 02:18
//1)
Type
ty=array[1..25] of integer;

Var
n,i:integer;
ar:ty;

procedure sortbutmeh(var ar:ty;n:integer);
Var
i,j,c:integer;
begin
for i:=1 to n-1 do
for j:=i+1 to n do
if ar[i]<ar[j] then
begin
c:=ar[i];
ar[i]:=ar[j];
ar[j]:=c;
end;
end;

begin
randomize;
readln(n);
writeln('First array:');
for i:=1 to n do
begin
ar[i]:=random(100);
write(ar[i]:4);
end;
sortbutmeh(ar,n);
writeln;
writeln('Array after sortbutmeh()');
for i:=1 to n do
write(ar[i]:4);
end.

//2)
Var
n:integer;

procedure ned(n:integer);
begin
case n of 
1:writeln('Понедельник');
2:writeln('Вторник');
3:writeln('Среда');
4:writeln('Четверг');
5:writeln('Пятница');
6:writeln('Суббота');
7:writeln('Воскресенье');
end;
end;

begin
readln(n);
ned(n);
end.

//3)
Var
s:string;

function lengthbutmeh(s:string):integer;
begin
while pos(' ',s)<>0 do
delete(s,pos(' ',s),1);
lengthbutmeh:=length(s);
end;

begin
readln(s);
writeln(lengthbutmeh(s));
end.
0,0(0 оценок)
Ответ:
dima102603
15.02.2021 12:38
1. 2. Имеются четыре основные составляющие информационной функции человека: прием (ввод) информации; запоминание информации (сохранение в памяти) ; процесс мышления (обработка информации) ; передача (вывод) информации. Компьютер включает в себя устройства, выполняющие эти функции мыслящего человека: устройства ввода; устройства запоминания — память; устройство обработки — процессор; устройства вывода.
3. В ходе работы компьютера информация через устройства ввода попадает в память. Затем процессор извлекает из памяти обрабатываемую информацию, работает с ней и помещает в нее результаты обработки. Полученные результаты через устройства вывода сообщаются человеку.
4.последовательность инструкций, предназначенная для исполненияустройством управления вычислительной машины. Программа — один из компонентов программногообеспечения. 
5.Главное отличие данных от программы в том, что первые являются носителем информационной нагрузки — файлами. Программа — средство создания, а также воспроизводства этой информационной нагрузки (в том виде, в котором она нужна пользователю).
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота