Написать программу, заполняющую массив из 30 случайными числами [0..80]. вывести массив. определить в этом массиве сумму чисел, кратных 3 определить количество отрицательных чисел. определить в этом массиве номер элемента, равного 0
1) Не понятно задание, в комментах допишу, как только пойму. 2)var t,c:array [1..10] of integer; i,sum:integer; begin for i:=1 to 10 do begin t[i]:=random(20+i); c[i]:=random(20000+i); end; for i:=1 to 10 do begin sum:=sum+t[i]*c[i]; end; for i:=1 to 10 do begin writeln('Количество товара ',i,' вида ',t[i],' Стоимость товара ',i,' вида ', c[i]); end; writeln('Общая сумма ',sum); end. 3) Мы опишем его так ves: array [1..31] of real; 4) var sum,x:real; n,i:integer; begin read(n); for i:=1 to n do begin read(x); sum:=sum+x; end; writeln(sum/n); end.
1) Не понятно задание, в комментах допишу, как только пойму. 2)var t,c:array [1..10] of integer; i,sum:integer; begin for i:=1 to 10 do begin t[i]:=random(20+i); c[i]:=random(20000+i); end; for i:=1 to 10 do begin sum:=sum+t[i]*c[i]; end; for i:=1 to 10 do begin writeln('Количество товара ',i,' вида ',t[i],' Стоимость товара ',i,' вида ', c[i]); end; writeln('Общая сумма ',sum); end. 3) Мы опишем его так ves: array [1..31] of real; 4) var sum,x:real; n,i:integer; begin read(n); for i:=1 to n do begin read(x); sum:=sum+x; end; writeln(sum/n); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку