tvin2005
13.01.2023 11:40

Нужна c++
составить программу, в которой
организовать ввод матрицы размера mxn из целых чисел;
вычесть из элементов третьей строки матрицы значение максимального элемента матрицы;
упорядочить элементы третьей строки по убыванию;
организовать ввод и вывод матрицы в виде отдельных функций.
​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ojitovtitan
21.04.2022 17:45
Код#include <iostream>constexpr double bites_to_megabytes(double a) {    return a / 8388608;}constexpr double megabytes_to_gigabytes(double a) {    return a / 1024;}int main() {    long long a;    short type;    bool is_correct = false;    double answer;    do {        std::cin >> a;        std::cout << "[1] Megabytes \n"                  << "[2] Gigabytes \n"                  << "Convert to [1] or [2]: ";        std::cin >> type;        if (type == 1 or type == 2) {            is_correct = true;        } else {            std::cout << "Meh. Try to type again. \n" << std:: endl;        }    } while (!is_correct);    switch (type) {        case 1:            answer = bites_to_megabytes(a);            break;        case 2:            answer = megabytes_to_gigabytes(bites_to_megabytes(a));            break;    }    std::cout << "An answer of conversion is " << answer << std::endl;    return 0;}
0,0(0 оценок)
Ответ:
lizagileva2015
21.01.2021 03:51
Разветвляющимися называется такой алгоритм, в котором выбирается один из нескольких возможных вариантов вычислительного процесса. каждый подобный путь называет "ветвью алгоритма".

признаком разветвляющегося алгоритма является наличие операций проверки условия. различают два вида условий –  простые  и  составные.

простым условием (отношением)  называется выражение, составленное из двух арифметических выражений или двух текстовых величин (иначе их еще ), связанных одним из знаков:

< - меньше,

> - больше,

< = - меньше, или равно

> = - больше, или равно

< > - не равно

= - равно

например, простыми отношениями являются следующие:

x-y> 10; k< =sqr(c)+abs(a+b); 9< > 11; ‘мама’< > ‘папа’.

в примерах первые два отношения включают в себя переменные, поэтому о верности этих отношений можно судить только при подстановке некоторых значений:

если х=25, у=3, то отношение x-y> 10 будет  верным, т.к. 25-3> 10

если х=5, у=30, то отношение x-y> 10 будет неверным, т.к. 5-30< 10

проверьте верность второго отношения при подстановке следующих значений:

а) k=5, a=1, b=-3, c=-8

b) k=65, a=10, b=-3, c=2

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота