mumuminecraft
09.06.2021 21:40

Составьте программу, которая выполняет чертеж детали и вычисляет ее площадь. маштаб 1 клетка - 20 пикселей, 1 клетка - 1 см. радиусы отверстий и вырезок (r1,r2,r3 и r4) вводятся с клавиатуры.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Soonthanyou
24.10.2020 19:17
ответ: 2;
Решение:
1)6 мегапикс. = 6000000 пикс;

2) Пусть x ширина картинки, тогда y ее длина.
Уравнение: X * 1,5Y = 6000000

3) Находим отношение (1,5). Получается уравнение: 6000000 / X * Y = 1,5;

4)Затем по пропорции находим произведение X и Y. Получилось: 6000000 / 1,5 = X * Y; 4000000 = X * Y;

5)Здесь картинка получается квадратом (условно, без уменьшение ширины, без 1,5);

6)Отсюда можно сделать вывод, что умножение Y на 1,5 дает ответ 3, а разрешение картинки равно: X * Y = 2 * 3 = 6 мегапикс.

P. S. Извиняюсь, что немного муторно, но Информатика есть инорматика...
0,0(0 оценок)
Ответ:
neponyatkiii
30.09.2020 15:35
Может быть, так:
uses graphABC;
Begin
setfontcolor(clRed);
writeln('Белеет парус одинокой');
setfontcolor(clBlue);
writeln('В тумане моря голубом!..');
setfontcolor(clDarkOrchid);
writeln('Что ищет он в стране далекой?');
setfontcolor(clDeepSkyBlue);
writeln('Что кинул он в краю родном?..');
setfontcolor(clDeepPink);
writeln('Играют волны - ветер свищет,');
setfontcolor(clMagenta);
writeln('И мачта гнётся и скрыпит...');
setfontcolor(clDarkGreen);
writeln('Увы! он счастия не ищет');
setfontcolor(clLime);
writeln('И не от счастия бежит!');
setfontcolor(clBrown);
writeln('Под ним струя светлей лазури,');
setfontcolor(clIndigo);
writeln('Над ним луч солнца золотой...')
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота