rmandzinDhsha
31.01.2021 22:58

Простое число
напишите программу, которая определяет является ли введенное число простым. если число простое выводиться "" иначе "нет". гарантируется что введенное число больше 1.

sample input 1:

3
sample output 1:

3 - простое
sample input 2:

4
sample output 2:

нет
питон через while

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
мур147
07.06.2020 13:32

1)Строкой называется последовательность символов, ограниченная символом с кодом 0, то есть '\0'. Из ее определения видно, что она является объектом переменной размерности. Местом хранения строки является массив символов.

2)Символы внутри строки индексируются (нумеруются), начиная с единицы. Каждый отдельный символ идентифицируется именем строки с индексом, заключенным в квадратные скобки.

3)

4)Существуют стандартные функции, которые определяют длину строки (количество символов в ней).

5)Возвращаемое значение оператора ++ зависит от его позиции относительно операнда. Если поставить его перед операндом ( префиксный оператор инкремента ), то к операнду прибавляется единица, а результатом является увеличенное значение операнда.

6)Различают два форматирования текста: прямое форматирование; стилевое форматирование. Форматирование символов — изменение значений свойств введённых символов: рисунка (шрифта), размера, начертания, цвета и т. д. Форматирование абзаца — изменение таких его свойств, как выравнивание, отступ первой строки, междустрочный интервал, отступы слева и справа, интервалы перед и после и др.

7)Если код цифры надо перевести в код числа, то просто вычитается 48: char c='9'; int i=c-48.

Объяснение:

0,0(0 оценок)
Ответ:
ekaterinaparsh1
04.11.2021 13:03

Program Example_180;

Uses crt;

Var m,n,k:word; {n – начальное количество сундуков с

золотом, m-ежегодная " прибыль”

Чахлика Бессмертного, k – “потребности”

Василисы Премудрой}

Sum,Years:word; {Sum – ежегодное накопление Чахлика

Бессмертного, Years-возраст Василисы

Премудрой}

Begin

Clrscr;

Write ('введите начальное количество сундуков с золотом: ’);

Readln(n);

Write(‘Введите ежегодный доход Чахлика: ’);

Readln(m);

Write(‘Введите “потребности” Василисы Премудрой: ’);

Readln(k);

Sum:=n; {Начальный “капитал” Чахлика}

Years:=18; {начальный возраст Василисы}

While Sum<=k do

Begin

Sum:=Sum+m;

Years:=Years+1;

End;

Writeln(‘Василисе уже исполнилось ’,Years,’ лет.‘);

Readkey;{Задержка изображения на экране}

End.

Объяснение:

я переводила вот так получилось

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота