Написать программу для получения действий в указанной системе счисления на паскале. вот что записано в тетради ученика: 101-10=11 101+10=111 101*10=1010 понятно, что арифметические действия выполняются не с десятичными числами, а с двоичными. надо написать программу получения таких действий в указанной системе счисления р ( ) для заданных чисел а и в ( ), записанных первоначально в десятичной системе счисления. при выводе чисел в системе счислению больше 10 используются заглавные латинские буквы. пример входных данных: 2 5 2 пример выходных данных: 101-10=11 101+10=111 101*10=1010
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018 // Внимание! Если программа не работает, обновите версию!
begin var s:=Arr('первое', 'второе','третье','четвертое','пятое'); var p,r:real; var c:char; Write('Введите первое число: '); Readln(r); for var i:=0 to 3 do begin Write('Выберите ',s[i], ' действие (a) сложить, b) вычесть,'); Write('c) умножить, d) разделить): '); Readln(c); Write('Введите ',s[i+1],' число: '); Readln(p); case c of 'a':r+=p; 'b':r-=p; 'c':r*=p; 'd':r/=p; end; Writeln('Результат: ',r) end end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку