ksenia112005
28.03.2021 21:47

Надо написать программу в pascal которая скажет поместится прямоугольный шкаф с длиной с,шириной a и высотой b в круглую дверь с радиусом r?

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
загадка27
27.08.2020 14:59

минимальный радиус двери в которую поместится шкаф равен радиусу описаной окружности вокруг прямоугольника равного размерам шкафа.

находим его по фрпмуле

R=\frac{\sqrt{a^{2}+b^{2}}}{2}

ну и пишем программу

var

   a, b : integer;

   r1, r2 : real;

begin

   writeln('введите:');

   write('высота шкафа a=');

   readln(a);

   write('ширина шкафа b=');

   readln(b);

   write('радиус двери R=');

   readln(r1);

   r2 := sqrt(sqr(a)+sqr(b))/2;

   if r1 >= r2 then writeln('шкаф пройдет') else writeln('шкаф не пройдет');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота