makismunguran
09.11.2020 15:34

Написать программу, принимающую произвольное количество строковых аргументов с командной строки, и возвращающая сумму их длин (т.е. общее количество символов). если аргумент не указан, или указан флаг -h - показывает справку. c# !

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Яна12133
17.11.2020 07:34

Тут используется собственная функция для нахождения степени числа.

 

#include <iostream>
using std::cout;
using std::cin;
using std::endl;

int powerFunction(int, int);

int main()
{
   int number, power;

   cout << "Enter A: ";
   cin >> number;
   cout << "Enter N: ";
   cin >> power;

   cout << number << " to the power of " << power
      << " = " << powerFunction(number, power) << endl;

   return 0;
}

int powerFunction(int n, int p)
{
   int temp = 1;

   for(int i = 0; i < p; i++)
   {
      temp *= n;
   }

   return temp;
}


Составить программу вычеслений степени числа а с натуральным показателем n.
0,0(0 оценок)
Ответ:
sashka4erepashka
05.02.2020 03:45
1. Для перевода из десятичной системы счисления в двоичную делим исходное число нацело на 2 (показатель системы в которую переводим) до тех пор, пока частное не станет меньше 2 (показателя системы в которую переводим). Далее с последнего частного (это всегда будет 1, за исключением когда исходное число равно 0) выписываем все остатки.
387:2 = 193 (остаток 1)
193:2 = 96 (остаток 1)
96:2 = 48 (остаток 0)
48:2 = 24 (остаток 0)
24:2 = 12 (остаток 0)
12:2 = 6 (остаток 0)
6:2 = 3 (остаток 1)
3:2 = 1 (остаток 1) Деление закончили, т.к. частное меньше 2.
Начиная с последнего частного выписываем число - 111000011 (2)
387 (10) = 111000011 (2).

2. В данном алфавите у нас 64 символов, т.е. для кодировки данного алфавита приходится 2^6 =64 - 6 бит на 1 символ.
Количество символов 870.
Чтобы найти информационный объем сообщения (текста) I, нужно умножить количество символов (отсчетов) N на число бит на символ (отсчет) K: 
I=N*K = 870*6 = 5220 бит.
В 1 байте 8 бит ⇒    5220 / 8 = 652.5 байт.

3. Дано: 
K=1600*1024=2^14 пикселей; Количество пикселей считается из разрешающей дисплея - произведении пикселей по горизонтали на кол-во по вертикали.
I=24 бит - битовая глубина.
Vвп=2 Мб = 2^24 бит.
Решение:
Используем формулы 
V=K*i;      Объем видеопамяти одной страницы - это произведение количества пикселей на глубину цвета в битах .
V= 2^14*3*2^3=3*2^17
m= Vвп/V, где m – это количество страниц экрана
m= 2^24/3*2^17 = (1/3) * 2^7 ≈ 42,7 страниц

4. Для хранения информации о моно звуке длительностью t секунд, закодированном с частотой дискретизации f Гц и глубиной кодирования B бит требуется t*B*f бит памяти. Для стерео звука это значение умножается на 2 (2 канала).
Получаем:
I=t*B*f  ⇒ f= I/ (B*f)
Переводим в системные единицы:
1 мин = 60 секунд.
1,3 Мбайт= 1,3*2^23 бит

Получаем:
f=1.3*2^23 / (8*60) ≈2.7*2^20 Гц = 2831155,2 ГЦ = 2,8 МГц
Но если честно, для задач школьного уровня - слишком большая частота - проверьте данные.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота