ilias1924
25.05.2023 05:21

Даны два персонажа сценарии: два друга. составьте программу, используя среду программирования и написать скрипты для каждого персонажа. так как они друзья, когда они встречаются, то обязательно друг друга словом "сэлем" один из них спрашивает "как дела? ", другой отвечает "! хорошо! ". известно
следующие условие: "когда нажат пробел, товарищи всегда идут на встречу, если касаются друг друга выдаётся сообщение "сэлем" "как дела? " "! хорошо! "" ! много . сейчас нужен.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Dimasik333000
21.11.2021 06:14
Язык программирования не указан, потому - самый простой вариант - программа на паскале. Даже на паскале задачу можно решать различными с массивом, без массива, со строками, без строк. Опять-таки, самый простой вариант - со строками.
var s,p:string; n,i:integer;
begin
writeln('Введите символы:');
readln(s);
n:=pos('.',s)-1;
writeln('n = ',n);
p:='';
for i:=1 to n do p:=s[i]+p;
writeln('а)');
writeln(p);
p:='';
if n mod 2 = 0 then i:=2 else i:=1;
while i<=n do
 begin
 p:=p+s[i];
 i:=i+2;
 end;
writeln('б)');
writeln(p);
end.

Пример:
Введите символы:Даны символы s1, s2, ... Известно, что символ s1 отличен от точки
n = 21
а)
 ,2s ,1s ыловмис ынаД
б)
Дн ивл 1 2 
0,0(0 оценок)
Ответ:
1234554321123456
29.08.2020 11:01

1 Центральная часть компьютера, выполняющая заданные программой преобразования информации и осуществляющая управление всем вычислительным процессом.

2 Процессоры конструктивно могут выполняться как в виде одной большой интегральной микросхемы — чипа, так и в виде нескольких микросхем, блоков электронных плат устройств.

3 Управля́ющий автома́т, устро́йство управле́ния проце́ссором — блок, устройство, компонент аппаратного обеспечения компьютеров.

4 Арифме́тико-логи́ческое устро́йство — блок процессора, который под управлением устройства управления служит для выполнения арифметических и логических преобразований над данными

5 технологический процесс изготовления полупроводниковых изделий и материалов; состоит из последовательности технологических и контрольных операций

а на шестой ответа не знаю(

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота