апрркн1
29.11.2020 15:06

Напишите программу паскаль ! в последовательности целых чисел найдите минимальное число и количество его повторений

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
insaimner
10.10.2020 03:58

Var

 Ch, n, Min, kMin: integer;

Begin

 Write('Введите кол-во чисел последовательности: ');

 ReadLn(n);

 

 Min := 0;

 kMin := 0;

 

 WriteLn('Введите целые числа в кол-ве ', n, ' штук:');

 For n := 1 to n do

 Begin

   Read(Ch);

   if (Ch < Min) or (kMin = 0) then

   Begin

     Min := Ch;

     kMin := 1;

   End

   else if (Ch = Min) then

     kMin := kMin + 1;

 End;

 

 WriteLn('Минимальное число: ', Min);

 WriteLn('Кол-во минимальный чисел: ', kMin);

End.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота