hassnallameozm4zm
26.11.2021 14:06

Напишите программу, которая для двух введенных с клавиатуры строк выводит ту строку, в которой больше слов. если количество слов одинаково - выводят обе строки.в pascal

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
kirilzz623
10.10.2020 03:41

будем считать что слова разделены пробелами. значит считаем количество пробелов, чем больше пробелов тем больше слов.

ВНИМАНИЕ! программа не проверяет на двойные пробелы, а так же на пробелы в начале и конце строк что может привести к неправильному подсчету слов при неаккуратном вводе строк. Все эти проверки можно добавить но это усложнит программу...

var

   s1, s2 : string;

   w1, w2 : integer;

begin

   write('строка 1: ');

   readln(s1);

   write('строка 2: ');

   readln(s2);

   for var i := 1 to s1.Length do if copy(s1, i, 1) = ' ' then w1 += 1;

   for var i := 1 to s2.Length do if copy(s2, i, 1) = ' ' then w2 += 1;

   if w1 > w2 then writeln(s1)

   else if w1 < w2 then writeln(s2)

   else writeln(s1, ' ', s2);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота