0033eg97
15.04.2021 04:01

Написать программу решения квадратного уравнения. программа должна проверять правильность исходных данных и в случае, когда коэффициент      при 2    степени неизвестного = 0, выводить соответствующее сообщение. ниже представлен рекомендуемый вид экрана    во время
работы программы (данные, введение пользователем, выделены полужирным шрифтом).  * решение квадратного уравнениявведите в одной строке значение коэффициентов нажмите      <   enter> => 12 27    -10корни уравнения:   х1= - 25.551х2= - 28.449  ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
melongemma
17.08.2022 16:09

1) Фамилия и Имя, дата рождения, номер телефона, куда будет приходить СМС оповещение или для входа на страницу и необходимо добавить свое фото. Но можно создать фейковый аккаунт ,где будут указаны недостоверная информация о вас, но если это заметят, то забанят.

2) У Facebook есть закладка о безопасности, где как раз говорят о предосторожности. Как уже отмечал в первом пункте , там люди могут создавать фейковые страницы и если к вам в друзья просится незнакомый человек , то нужно как-то удостовериться о его хороших и честных намерениях. Обычно это делается путем осмотра его друзей, недавних публикации и вообще активности. Если все его публикаций были сделаны за несколько дней и о нем мало что известно, то скорее всего этот человек мошенник.

3) Хоть Facebook пытается всегда поддержать пользователя, это не означает ,что они ,в случае обмана, смогут вычислить и наказать злоумышленника. Т.е. конечно не нужно о себе слишком подробно писать на странице, вплоть до места постоянного проживания и номера банковской карты. В любом случае, есть функция приватности предоставления информации, типа показывать данные о себе только определенным людям или только друзьям. Это уберечь вас от опасностей.

4)Это ссылки, картинки, файлы , музыка, аудиозаписи и видеозаписи, сообщения. Короче, всё как в стандартном мессенджере.

0,0(0 оценок)
Ответ:
kmtva04
28.02.2023 02:30

using System;

namespace restless

{

   class Class3

   {

       static void Main()

       {

           int _choice, _size, _sum = 0;

               Console.WriteLine("Введите количество строк(столбоцов) матрицы: ");

               _size = Int32.Parse(Console.ReadLine());

               int[,] matrix = new int[_size, _size];

               Console.WriteLine("Теперь введите значения элементов матрицы: ");

               for (int i = 0; i < _size; i++)

               {

                   for (int j = 0; j < _size; j++)

                   {

                       matrix[i, j] = Int32.Parse(Console.ReadLine());

                   }

               }

           do

           {

               Console.WriteLine("\n1.Вывести матрицу на экран\n2.Вывести сумму элементов не лежащих на главное диагонали\n0.-Выход\n");

               _choice = Int32.Parse(Console.ReadLine());

               switch (_choice)

               {

                   case 1:

                       for (int i = 0; i < _size; i++)

                       {

                           for (int j = 0; j < _size; j++)

                           {

                               Console.Write(matrix[i, j] + " ");

                           }

                           Console.WriteLine();

                       }

                       break;

                   case 2:

                       for (int i = 0; i < _size; i++)

                           for (int j = 0; j < _size; j++)

                               if (i != j)

                                   _sum += matrix[i, j];

                       Console.WriteLine($"\nСумма элементов, не лежащих на главной диагонали: {_sum}");

                       break;

                       

               }

           } while (_choice != 0);

       }

   }

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота