Sake111
16.11.2021 12:36

Напишите программу в lazarus для суммы s в списке радиокнопок выбирается вид вклада («пенсион- ный» – 17% годовых, «до востребования» – 3% годовых, «молодежный» – 14% годовых и указать сумму вклада через один, два, три года с учетом начисляемых процентов. суммы вкладов выводить в компонент memo.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vika2075
13.12.2022 23:09
Количество информации в сообщении обычно равно количеству бит (округляемому до ближайшего целого с избытком) , которое необходимо для воспроизведения текста сообщения. то есть в сообщении 10101010 информации - 8 бит, в сообщении "погода сегодня будет зимняя, снег не растает, солнце взойдет утром и сядет вечером" - 350 бит (если считать, для простоты, что в языке 32 буквы) . в сообщении e=hν информации, если кодировку ситать юникодом, - 8 байт (64 битa) информации. но вот ценность этих сообщений несопоставима.  но ценность информации не есть величина неизбывная и строго измеряемая для данного сообщения. она всегда зависит от того, кому эта информация предназначена, и от того, что путного можно извлечь из неё, а значит - слабо формализуема. в конце концов, запросто можно представить себе (путь и фантастическую) 
0,0(0 оценок)
Ответ:
alinka660066
25.05.2022 10:28
{ ответ дан на языке Pascal }
//1-ая задача
PROGRAM Solution(INPUT, OUTPUT);

VAR
  num: INTEGER;
  n1, n2, n3: INTEGER;

BEGIN
  WRITE('Введите 3-значное число: ');
  READ(num);

  n1 := (num DIV 100);
  n2 := (num MOD 100 MOD 10);
  n3 := (num MOD 100 DIV 10);
  IF(n1 + n2 + n3) MOD 2 = 0
  THEN WRITELN('Чётное')
  ELSE WRITELN('Нечётное');
END.

//2-ая задача
PROGRAM Solution(INPUT, OUTPUT);

VAR
  num: INTEGER;
  n1, n2, n3: INTEGER;

BEGIN
  WRITE('Введите 3-значное число: ');
  READ(num);

  n1 := (num DIV 100);
  n2 := (num MOD 100 MOD 10);
  n3 := (num MOD 100 DIV 10);
  IF(num * num) = (n1 * n1 * n1) + (n2 * n2 * n2) + (n3 * n3 * n3)
  THEN WRITELN('Равен')
  ELSE WRITELN('Не равен');
END.

//3-я задача
PROGRAM Solution(INPUT, OUTPUT);

VAR
  a, b, c: INTEGER;

BEGIN
  WRITE('Введите a, b, c: ');
  READ(a, b, c);

  IF(a = b) OR (b = c) OR (c = a)
  THEN WRITELN('Равнобедренный')
  ELSE WRITELN('Не равнобедренный');
END.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота