alexeremka
14.05.2023 13:03

Решить это в с++ абай и айбар любят массивы. недавно у абая был день рождения, поэтому айбар подарил абаю много подарков, в том числе массив. они сразу же начали играть с ним и абай придумал такую игру: нужно посчитать количество подотрезков массива, у которых количество различных чисел не больше
k. подотрезком называется часть массива, которая может быть получена удалением некоторого (возможно нулевого) количества элементов с начала и с конца массива. айбар успешно справился с этой , а сможете ли справиться вы? формат входных данных в первой строке входных данных заданы 2 целых числа n и k
(1 ⩽ n ⩽ 106 , 0 ⩽ k ⩽ n). во второй строке задан массив a из n целых неотрицательных чисел (0 ⩽ ai ⩽ 109 ). формат выходных данных в единственной строке выведите число - ответ на . пример стандартный ввод стандартный вывод 10 3 1 5 2 1 5 3 4 1 1 5 32

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Викусик1258
24.02.2021 22:28

Var a, b, c:integer;

Begin

Readln(a,b,c);

If a>=b+c then Writeln('Нет' )

Else if b>=a+c then Writeln('Нет')

Else if c>=a+b then Writeln('Нет')

Else Writeln('Да');

End.

Использование русских букв в названии переменной (с) это очень сильно, а ещё кавычки не `, а ' должны быть. Код можно еще улучшить избавившись от большого кол-ва проверок if т. к. это замедляет компиляцию

Var a, b, c:integer;

Begin

Readln(a,b,c);

If (a>=b+c) or (b>=a+c) or (c>= a+b) then Writeln('Нет' )

Else Writeln('Да');

End.

0,0(0 оценок)
Ответ:
Ionutamaria90
17.06.2020 21:56
PascalABC.NET 3.4.2, сборка 1847 от 28.10.2018Внимание! Если программа не работает, обновите версию!

function СуммаКвадратовЦифр(Число: integer): integer;

begin

 Result := 0;

 while Число > 0 do

 begin

   Result += Sqr(Число mod 10);

   Число := Число div 10

 end

end;


function ЧислоПервоклассное(Число: integer): boolean;

begin

 Число := Abs(Число); // защита от злобных буратинок

 var L:=new SortedSet<integer>;

 L.Add(Число);

 repeat

   case Число of

     0, 2, 3:

       begin

         Result := False;

         Exit

       end;

     1:

       begin

         Result := True;

         Exit

       end;

     else

     begin

       Число := СуммаКвадратовЦифр(Число);

       if L.Contains(Число) then

       begin

         Result:=False;

         Exit

       end

       else L.Add(Число)

     end

   end

 until False // бесконечный цикл

end;


begin

 var (НижняяГраница, ВерхняяГраница) := ReadInteger2;

 var Количество := 0;

 for var ОчередноеЧисло := НижняяГраница to ВерхняяГраница do

   if ЧислоПервоклассное(ОчередноеЧисло) then Inc(Количество);

 Количество.Println

end.

1 10020
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота