Alino4ka58258
28.05.2023 03:34

Написать программу, находяшую сумму и произведение цифр четырехзначного числа

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
дима4класс1
10.10.2020 03:20

var

   a, s, p : integer;

   

begin

   p := 1;

   repeat a := ReadInteger('введите 4-х значное число: ') until (a > 999) and (a < 10000);

   while a > 0 do begin      

       s += a mod 10;

       p *= a mod 10;

       a := a div 10;

   end;

   writeln('сумма ', s);

   writeln('произведение ', p);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота