Annkeklol
16.02.2023 05:44

Составить программу нахождения s всех граней куба, объема куба и среднее арифметическое n чисел

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Катя111111177796
24.09.2021 14:56

stdout:

/temp/compiling/source.bas(1) error 3: Expected End-of-Line, found 'Pascal'

Pascal;

^

/temp/compiling/source.bas(2) error 10: Expected '=', found ';'

Var;

  ^

/temp/compiling/source.bas(3) error 3: Expected End-of-Line, found '�'

   a,b:integer;

^

/temp/compiling/source.bas(4) error 10: Expected '=', found ';'

Begin;

    ^

/temp/compiling/source.bas(5) error 3: Expected End-of-Line, found '�'

   read(a,b);

^

/temp/compiling/source.bas(6) error 3: Expected End-of-Line, found '�'

   write(a+b);

^

/temp/compiling/source.bas(7) error 10: Expected '='

End.

^

/temp/compiling/source.bas(9) error 3: Expected End-of-Line, found '�'

Язык C++

^

/temp/compiling/source.bas(11) error 145: Only valid in -lang fb or deprecated or fblite, found 'using'

using namespace std;

^

/temp/compiling/source.bas(12) error 6: Expected '(', found 'main'

int main() {

   ^

/temp/compiling/source.bas(12) error 132: Too many errors, exiting

stderr:

0,0(0 оценок)
Ответ:
Лераuse
20.02.2023 03:46

1)

a = [12,32,51,2,5,-10,-20,23,-23] # задаете любой массив

a.sort()

minim = 0

maxim = 0

for i in range(len(a)):

   if a[i] % 2 == 0:

       minim = a[i]

       break

a = list(reversed(a))

for i in range(len(a)):

   if a[i] % 2 == 0:

       maxim = a[i]

       break

print(minim)

print(maxim)

2)

a = [12,32,51,2,1,-10,-20,21,-23]

a.sort()

minim = 0

maxim = 0

for i in range(len(a)):

   if a[i] % 10 == 5:

       minim = a[i]

       break

a = list(reversed(a))

for i in range(len(a)):

   if a[i] % 10 == 5:

       maxim = a[i]

       break

if minim == 0 and maxim == 0:

   print('No')

else:

   print(minim)

   print(maxim)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота