legoman1858
29.08.2022 04:03

Составить программу в кумире для : 3) составить программу, которая находит наименьшее количество множителей ряда 2*2,1*2,2*2,3* … , произведение которых превышает число 12; 3) составить программу, которая находит наименьшую сумму ряда 2+4+8+16 … , превышающую введённое число; 3) составить
программу, которая находит наименьшую сумму ряда 1+4+7+10+ … , превышающую число 17;

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
lara1906
13.05.2020 10:53
Начнем...
Я люблю сидеть в интернете, общаться по Skype, и просиживать в соц.сетях, а также сидеть на различных сайтах( пкречислите какие). Однако интернет - не только огромное количевство информации, но и куча вирусов, всплывающих окон которые подталкивают к суициду, прекращение есть пищи, насилие, порнография и многое другое. Обычным пользователям на легко жить таким образом. Более опытные ставят на браузера специальные плагины, с которых можно избавиться хотя-бы от рекламы. Но куча других опасностей как спам. Например подруга отправила ссылку на сайт, открыв предлагается ввести номер, после чего с вашего счета снимается 300 рублей. Однако можно защититься от всего этого, ставя антивирусы. Но у антивирусов есть огромный недостаток, так сказать защита от вирусов мадам, а в замен скорость вашего компьютера. Естественно что антишманти вам хотя не всегда, но например на слабых компьютерах это слишком замедлит работу. Особенно если вы решили купить недорогой ноутбук например, и решили что он будет для работы, там важные документы, поэтому ставлю антивирус. В итоге получив защиту от вирусов, вы взамен отдаете производительность. Интернет может быть безопасным, однако лучше предостеречься и поставить антивирус.
0,0(0 оценок)
Ответ:
ilychshetebyaa
23.02.2023 04:32
Var a:array[1..100000] of longint;i,n,max,min:longint;   
begin     
Assign(input,'input.txt');Reset(input);     
Assign(output,'output.txt');Rewrite(output);     
readln(n);
min:=maxint;
max:=0;     
for i:= 1 to n do begin       
readln(a[i]);       
if a[i] mod 2 = 0 then begin         
if a[i] > max then max:=a[i];       
if a[i] < min then min:=a[i];       
end;     
end;     
Writeln('min = ',min);     
Writeln('max = ',max);     
Close(input);Close(Output);   
end.
Например 
вводишь в файл input.txt
5
1
2
3
4
5
он в файле output.txt вывидет
min = 2
max = 4
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота