stipstip353p090as
03.11.2020 11:16

Напишите программу, которая рассчитывает сумму за потребленную энергию по текущему показателю p2 и показателю месяца, с учетом тарифа - с руб/кват. если сумма превысит 1500 руб. вывести на экран "перерасход", если нет, то вывести "норма".

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Пава1305
13.01.2020 03:35

Привет, код ниже, для справки по функциям советую посетить MSDN.
Если остаются вопросы так же есть хороший сайт как METANIT, там ты можешь найти простые примеры и простую документацию.
Если хочется проверить работаю кода, то есть прекрасный ресурс как Repl It.
Если есть вопросы, пиши в комментариях. За дополнительной информацией пиши в ЛС.

за отметку "Лучшее решение" и нажатую кнопочку и у меня в профиле.
Так же в моем профиле вы можете найти полезные ссылки на ресурсы описанные выше.



using System;

class MainClass {
  public static int (int[] array)
  {
    int result = 1;
   
    foreach (int element in array)
    {
      if (0 > element)
      {
        result *= element;
      }
    }
   
    return result;
  }

  static void Main()
  {
    Console.WriteLine("Please, enter length of array: ");
    int sizeOfArray = Convert.ToInt32(Console.ReadLine());
   
    int[] array = new int[sizeOfArray];
   
    for (int i = 0; i < sizeOfArray; ++i)
    {
      Console.WriteLine("Please, enter array entry: ");
      array[i] = Convert.ToInt32(Console.ReadLine());
    }
   
    int productOfNegativeNumbers = (array);
    Console.WriteLine("Product of negative numbers is: {0}", productOfNegativeNumbers);
  }
}
0,0(0 оценок)
Ответ:
volkovaw
09.01.2023 07:29

70, 35, 43, 132, 121, 11, 60, 64, 24, 31

Объяснение:

1) Изначально s = 0, затем на каждой из 12 – 6 + 1 = 7 итераций к ней прибавляется 10, итого получится 70

2) Аналогично, s = 0 + 7 * (8 – 3) = 35

3) Итерация с i = 1: k = 2 * 4 + 1 = 9. Итерация с i = 2: k = 2 * 9 + 2 = 20. Итерация с i = 3: k = 2 * 20 + 3 = 43.

4) s = 0 + 12 * 11 = 132  

5) s = 0 + 11 * (12 – 1) = 121

6) u = 26 – 1 – 2 – 3 – 4 – 5 = 11

7) s = 4 + 5 + … + 11 = 60

8) s = 1 * 2 * 2 * … * 2 (8 – 3 + 1 раз) = 64

9) y = 0 + 4 * 1 + 4 * 2 + 4 * 3 = 24

10) s = 3 + 2 * 2 + 2 * 3 + 2 * 4 + 2 * 5 = 31

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота