darina2605
16.01.2023 19:59

Написать программу в среде кумир, которая вычисляет площадь и периметр треугольника, прямоугольника и круга площади и периметры фигур вычисляются по следующим формулам: периметр треугольника: p = a + b + c площадь треугольника: s = √(p(p-a)(p-b)(p- где p = p/2 периметр прямоугольника: p = 2(a +
b) площадь прямоугольника: s = ab периметр круга: p = 2πr площадь круга: s = πr2

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ruslana0506
26.01.2024 12:58
Конечно! Вот программа, написанная на языке Кумир, которая вычисляет площадь и периметр треугольника, прямоугольника и круга:

```kotlin
program perimeterAndArea;

var figure: char;
var p, a, b, c, r, s: real;

begin
writeln("Выберите фигуру (треугольник - t, прямоугольник - r, круг - c): ");
readln(figure);

if figure = 't' then
begin
writeln("Введите стороны треугольника: ");
readln(a, b, c);

p := (a + b + c) / 2; // находим полупериметр треугольника
s := sqrt(p * (p - a) * (p - b) * (p - c)); // находим площадь треугольника

writeln("Периметр треугольника: ", 2 * p);
writeln("Площадь треугольника: ", s);
end

else if figure = 'r' then
begin
writeln("Введите стороны прямоугольника: ");
readln(a, b);

p := 2 * (a + b); // находим периметр прямоугольника
s := a * b; // находим площадь прямоугольника

writeln("Периметр прямоугольника: ", p);
writeln("Площадь прямоугольника: ", s);
end

else if figure = 'c' then
begin
writeln("Введите радиус круга: ");
readln(r);

p := 2 * pi * r; // находим периметр круга
s := pi * r * r; // находим площадь круга

writeln("Периметр круга: ", p);
writeln("Площадь круга: ", s);
end

else
begin
writeln("Некорректный выбор фигуры!");
end;
end.
```

Пошаговое решение:

1. Код программы начинается с ключевого слова "program", за которым следует название программы "perimeterAndArea".

2. Объявляем переменные, которые будут использоваться в программе: `figure` для выбора фигуры, `p` для периметра, `a`, `b`, `c` для сторон фигур, `r` для радиуса круга, `s` для площади.

3. Выводим на экран сообщение с просьбой выбрать фигуру.

4. Считываем введенную пользователем букву в переменную `figure`.

5. С помощью оператора `if` проверяем выбор фигуры. Если пользователь выбрал треугольник ('t'), то выполняем код внутри блока `begin...end`.

6. Выводим на экран сообщение с просьбой ввести стороны треугольника.

7. Считываем введенные стороны треугольника в переменные `a`, `b`, `c`.

8. Вычисляем полупериметр треугольника, записываем его в переменную `p`.

9. Вычисляем площадь треугольника по формуле Герона, записываем ее в переменную `s`.

10. Выводим на экран значения периметра и площади треугольника.

11. Если пользователь выбрал прямоугольник ('r'), то выполняем код внутри блока `begin...end`.

12. Выводим на экран сообщение с просьбой ввести стороны прямоугольника.

13. Считываем введенные стороны прямоугольника в переменные `a` и `b`.

14. Вычисляем периметр прямоугольника и записываем его в переменную `p`.

15. Вычисляем площадь прямоугольника и записываем ее в переменную `s`.

16. Выводим на экран значения периметра и площади прямоугольника.

17. Если пользователь выбрал круг ('c'), то выполняем код внутри блока `begin...end`.

18. Выводим на экран сообщение с просьбой ввести радиус круга.

19. Считываем введенный радиус круга в переменную `r`.

20. Вычисляем периметр круга и записываем его в переменную `p`.

21. Вычисляем площадь круга и записываем ее в переменную `s`.

22. Выводим на экран значения периметра и площади круга.

23. Если пользователь выбрал другую букву, выводим сообщение о некорректном выборе фигуры.

24. Конец программы.

Надеюсь, данное пошаговое решение поможет вам понять, как работает программа. Если у вас возникнут вопросы, не стесняйтесь задавать!
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота