1)составьте программу, которая запрашивает цифру от 1 до 3 и русует эту цифру в графическом окне.2)составьте программу, чтобы рисовалась любая вселенная цифра от 0 до 9.язык паскаль. !
writeln('Введите цифру от 1 до 3:');
readln(digit);
case digit of
1: DrawOne();
2: DrawTwo();
3: DrawThree();
end;
readln;
closegraph;
end.
Программа сначала инициализирует графическое окно, а затем запрашивает цифру от пользователя. В зависимости от выбранной цифры, вызывается соответствующая процедура для рисования этой цифры. В конце программы окно закрывается.
2) Программа, чтобы рисовалась любая цифра от 0 до 9:
procedure DrawDigit(digit: integer);
var
i, j: integer;
begin
for i := 1 to 5 do
begin
for j := 1 to length(DigitPatterns[digit]) do
begin
if DigitPatterns[digit][j] = '#' then
line(j * 10, i * 10, j * 10, i * 10);
end;
end;
end;
var
num: integer;
gd, gm: smallint;
begin
gd := Detect;
InitGraph(gd, gm, '');
writeln('Введите цифру от 0 до 9:');
readln(num);
DrawDigit(num);
readln;
closegraph;
end.
В данной программе для каждой цифры от 0 до 9 создан паттерн, представляющий собой строку символов "#" и "перевод каретки" (#10). Этот паттерн используется для рисования каждой цифры. В цикле по строке паттерна проверяется символ и при нахождении символа "#" рисуется горизонтальная линия. В результате получается изображение выбранной цифры.
Если возникнут еще вопросы, не стесняйтесь спрашивать!
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку