Ananasabricos
18.02.2020 16:12

Напишите программу, которая генерирует двовимирний массив 6x6 положительных действительно случайных чисел lazarus

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
хорошист378
03.09.2020 14:08

using System;

using System.Linq;

namespace restless

{

   class Program

   {

       static double Average(double[] arr)

       {

           double _sum = 0;

           for (int i = 0; i < arr.Length; i++)

               _sum += arr[i];

           return _sum / arr.Length;

       }

       

       static Tuple<double, double> SumProdToLastPositive(double[] arr)

       {

           double _sum = 0, _prod = 1;

           int i = arr.Length - 1;

           while(arr[i] <= 0)

           {

               i--;

           }

           for (int j = 0; j <= i; j++)

           {

               _sum += arr[j];

               _prod *= arr[j];

           }

           return Tuple.Create(_sum, _prod);

       }

       static double[] RemoveElements(double[] arr, double a, double b)

       {

           int startSize = arr.Length;

           var tmp = arr.Cast<double>().ToList();

           for (int i = 0; i < tmp.Count; i++)

           {

               if (arr[i] >= a && arr[i] <= b)

               {

                   tmp.Remove(arr[i]);

               }

           }

           for (int i = 0; i < tmp.Count; i++)

           {

               arr[i] = tmp[i];

           }

           for (int i = tmp.Count; i < startSize; i++)

               arr[i] = 0;

           return arr;

       }

       static void Main()

       {

           Random rnd = new Random();

           double[] arr = new double[10];

           Console.WriteLine("Введите элементы массива (каждый на новой строке): ");

           for (int i = 0; i < 10; i++)

               arr[i] = Convert.ToDouble(Console.ReadLine());

           /*Для удобства проверки сделана генерация только целых чисел*/

           Console.Write("Исходный массив: ");

           for (int i = 0; i < 10; i++)

           {

               Console.Write($"{arr[i]} ");

           }

           Console.WriteLine();

           //функция, которая вернет нам среднее арифметическое

           Console.WriteLine($"Среднее арифметическое: {Average(arr)}");

           //функция, которая вернет нам сумму и произведение элементов до последнего положительного

           Console.WriteLine($"Сумма и произведение до последнего положительного: {SumProdToLastPositive(arr)}");

           /*Последняя функция возвращает массив, мы его запишем в переменную g, а затем выведем на экран.

            Хотя можно было передать массив с модификатором ref и изменять его, ну так тоже пойдёт.

            */

           Console.Write("Изменённый массив после удаления элементов из промежутка [a, b]: ");

           var g = RemoveElements(arr, 2.0, 5.0);

           

           for (int i = 0; i < g.Length; i++)

               Console.Write(g[i] + " ");

       }

   }

}

0,0(0 оценок)
Ответ:
карина5647
11.06.2020 18:21

Какие качества нужны, чтобы стать хорошим специалистом?

Трудолюбие  

ответственность  

Умение работать в команде  

Стремление к личностному росту, развитию профессиональных качеств .

Лояльность

Как ты понимаешь высказывание: «Самая трудная профессия - быть человеком»?

Действительно, самой трудной профессией является быть человеком. В нашей жизни всё зависит от самого человека, что он будет считать смыслом своей жизни, к чему будет стремиться, на что будет тратить свои силы. Трудно жить среди людей, но надо постоянно стремиться стать лучше. Нужно всегда быть человеком, думать о других, стараться творить добро, приносить людям пользу. Человеком надо быть всегда и везде, каждую минуту, без выходных и праздников. Мы должны пробовать облегчить жизнь другим людям, поддерживать и любить своих близких, в том, чтобы жить ради других людей и заключается предназначение каждого человека, человек должен быть человечным. Надо стараться быть добрее и гуманнее, справедливее по отношению к другим людям, хотя это и является самой трудной профессией - быть человеком.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота