olegneoleg
06.06.2020 05:00

Нужно в паскале. напишите программу которая вводит с клавиатуры числа до тех пор пока не будет введено число 0. в конце работы программы на экран выводится сумма и произведение введенных чисел (не считая 0).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Св55
10.10.2020 01:53

Program n_1;

var a, b, n: double;

begin

   read (n);

   a:=n; b:=n;

   if n<>0 then read (n);

   while (n<>0) do begin

       a:=a+n;

       b:=b*n;

       read(n);

   end;

   writeln('Сумма чисел равна ', a:0:10, ' а их произведение ', b:0:10);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота