lizahelp7
18.03.2023 02:36

Напишите программу которая вводит из файла весовую матрицу и строит для него минимальное остовное дерево. ! 10б

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
борщ7
30.01.2021 20:26
//PascalABC.NET 3.0, сборка 1088
begin
  var a:=ReadLines('infile.txt').ToArray;
  var n:=a.Length;
  Writeln('*** Исходная информация ***');
  // фамилия, имя, возраст, рост, вес
  a.PrintLn(NewLine);
  Writeln('*** Задание 1 ***');
  var sves:real:=0;
  var srost:real:=0;
  foreach var s in a do begin
    srost+=StrToFloat(s.ToWords.ElementAt(3));
    sves+=StrToFloat(s.ToWords.ElementAt(4))
    end;
  Writeln('Средний рост равен ',srost/n:5:1);
  Writeln('Средний вес равен ',sves/n:4:1);
  srost/=n; sves/=n;
  Writeln('*** Задание 2 ***');
  var f2:=OpenWrite('rost.txt');
  foreach var s in a do begin
    var ss:=s.ToWords;
    var rost:=StrToFloat(ss.ElementAt(3));
    if rost>srost then begin
      var s0:=ss.Take(3).ToArray;
      var s1:=s0[0]+' '+s0[1]+', '+s0[2];
      Writeln(s1);
      Writeln(f2,s1)
      end
    end;
  f2.Close;
  Writeln('*** Задание 3 ***');
  f2:=OpenWrite('ves.txt');
  foreach var s in a do begin
    var ss:=s.ToWords;
    var ves:=StrToFloat(ss.ElementAt(4));
    if ves<sves then begin
      var s0:=ss.Take(3).ToArray;
      var s1:=s0[0]+' '+s0[1]+', '+s0[2];
      Writeln(s1);
      Writeln(f2,s1)
      end
    end;
  f2.Close
end.

Тестовое решение:
*** Исходная информация ***
Иванов Игорь 14 158 47.4
Петров Павел 14 161 58.3
Козлов Кирилл 15 160 60.3
Сидорова Мария 14 156 45.9
Тяпкина Наталья 15 158 46
Ляпкин Алексей 15 161 58.6
Мамочкин Константин 14 157 52.8
*** Задание 1 ***
Средний рост равен 158.7
Средний вес равен 52.8
*** Задание 2 ***
Петров Павел, 14
Козлов Кирилл, 15
Ляпкин Алексей, 15
*** Задание 3 ***
Иванов Игорь, 14
Сидорова Мария, 14
Тяпкина Наталья, 15
0,0(0 оценок)
Ответ:
Steam1112
20.02.2023 19:11
// PascalABC.NET 3.0, сборка 1088
begin
  var n:=ReadLnString('Введите число: ');
  n:=n.Where(x->x in ['0'..'9']).JoinIntoString('');
  Writeln('Принятое число: ',n);
  var a:=ReadLnChar('Введите искомую цифру: ');
  Writeln('Количество цифр в числе равно ',n.Length);
  if n[1]=n[n.Length] then Writeln('Первая цифра равна последней')
  else Writeln('Первая цифра не равна последней');
  if Pos(a,n)>0 then Writeln('Цифра ',a,' входит в число')
  else Writeln('Цифра ',a,' не входит в число')
end.

Тестовое решение:
Введите число: тут спрятано 456. по частям 764 наше 03число
Принятое число: 45676403
Введите искомую цифру: 0
Количество цифр в числе равно 8
Первая цифра не равна последней
Цифра 0 входит в число

"Школьный вариант"
// PascalABC.NET 3.0, сборка 1088
var
  n:longint;
  i,k:integer;
  sn:string;
  a:char;
begin
  Write('Введите число: '); Readln(n);
  Str(n,sn);
  Write('Введите искомую цифру: '); Readln(a);
  k:=Length(sn);
  Writeln('Количество цифр в числе равно ',k);
  if sn[1]=sn[k] then Writeln('Первая цифра равна последней')
  else Writeln('Первая цифра не равна последней');
  if Pos(a,sn)>0 then Writeln('Цифра ',a,' входит в число')
  else Writeln('Цифра ',a,' не входит в число')
end.

Тестовое решение:
Введите число: 3476573
Введите искомую цифру: 7
Количество цифр в числе равно 7
Первая цифра равна последней
Цифра 7 входит в число
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота