Ди1501
13.09.2021 00:23

Язык - паскаль. в магазине продаётся шоколадка, стоимостью x рублей и y копеек. у нас есть a рублей b копеек. сколько можно купить шоколадок(f)? сколько у нас останется рублей(c)? сколько у нас останется копеек(d)? 15 ! ,

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
stnicolay2007
10.10.2020 01:27
5.Пирожок в столовой стоит a рублей и b копеек. Определите, сколько рублей и копеек нужно заплатить за n пирожков. Программа получает на вход три числа: a, b, n и должна вывести два числа: стоимость покупки в рублях и копейках.
0,0(0 оценок)
Ответ:
marrycat1
10.10.2020 01:27
Var x,y,a,b,c,d,f:integer;
begin
read(x,y,a,b);
xy:=x*100+y;
ab:=a*100+b;
f:=ab div xy;
if ab-xy*f >100 then c:=(ab-xy*f) div 100 else c:=0;
d:= ab-xy*f;
writeln(f,’ шоколадок можно купить, а ещё останется ‘,c,’рублей и ‘,d,’копеек.’)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота