Danil3250
21.08.2020 19:06

А)составьте программу ,которая позволяет с клавиатуры ввести значения переменных x и y,и проверяет истинность высказывания: "хотя бы одно из чисел нечётное„. б)составьте программу ,которая позволяет с клавиатуры ввести значения переменных x и y,и проверяет истинность высказывания: "каждое из чисел чётное„.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Nikita43242
27.08.2020 14:29

Номер 1

Program n_1;

Var x, y:integer;

Begin

   read(x, y);

   if (x mod 2 = 1) or (y mod 2 = 1) then writeln('По крайней мере одно из чисел нечетное')

   else writeln('Нечетных чисел здесь нет');

End.

Номер 2

Program n_2;

Var x, y:integer;

Begin

   read(x, y);

   if (x mod 2 = 0) and (y mod 2 = 0) then writeln('Оба числа четные')

   else writeln('По крайней мере одно из чисел нечетное');

End.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота