victoriabetenecova
20.11.2020 14:26

Напишите программу по тексту в паскале или на си+++ или на питоне пусть дана последовательность чисел a1, : , an, состоящая из 0 и 1. пару чисел (ai, aj), таких что i < j, j - i = k и ai ¹ aj, назовем неправильной. индексом неправильности последовательности (инп) назовем количество неправильных пар (ai, aj) в ней. инп легко посчитать за один проход по массиву, в котором хранятся элементы последовательности: переберем все i от 1 до n - k и сравним их с соответствующими j = i + k. если инп равен 0, то ответ в ok и никаких чисел менять в ней не нужно. иначе для каждого из элементов последовательности найдем инп после изменения этого элемента. при изменении одного числа в последовательности нулей и единиц может измениться только правильность пар (ai-k, aj) и (ai, ai+k), если они, конечно, существуют. дело в том, что i - k может быть меньше 1, или i + k - больше n. в этих случаях соответствующая пара отсутствует. значит в результате изменения одного числа, инп может измениться на -2, -1, 0, +1 или +2. если в результате изменения какого-то из чисел инп станет равным 0 - то ответ ok и номер измененного элемента, иначе - ответ fail. данный алгоритм работает за линейное относительно длины последовательности время.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Ответ:
petrgulyaev06
05.07.2022 16:03

{pascalabc}

program f0rwardirop;

var  

  r,x,y: real;

  b: boolean;

  i: integer;

  s: string;

begin

  s: =' -=alphaeus=- ';

  for i: =1 to 22 do begin write(s[i]); sleep(200) end;

  writeln; write('ok, введите r = '); readln(r);

  write('теперь введите х = '); readln(x);

  write('и, наконец, введите y = '); readln(y);

  if x> =0 then

    if (x*x+y*y < = r*r) then b: = true else b: =false

    else

      if (abs(x) < =r) and (abs(y) < =r) and (abs(x) < = abs(y)) then b: = true else b: =false;

  if b then writeln('точка (',x,',',y,') принадлежит закрашенной области')

  else writeln('точка (',x,',',y,') не принадлежит закрашенной области');

end.

0,0(0 оценок)
Ответ:
XxXBulykXxX
03.02.2022 18:45

ответ: кратковременная память

кратковременная память удерживает материал иного типа, нежели непосредственный отпечаток сенсорной информации. в данном случае удерживаемая информация представляет собой не полное отображение событий, которые произошли на сенсорном уровне, а непосредственную интерпретацию этих событий. например, если при вас произнесли какую-то фразу, вы запомните не столько составляющие ее звуки, сколько слова. обычно запоминается 5-6 последних единиц из предъявленного материала. сделав сознательное усилие, вновь и вновь повторяя материал, можно удерживать его в кратковременной памяти на неопределенно долгое время.

долговременная память.

существует явное и убедительное различие между памятью о только что случившемся событии и событиях далекого прошлого. долговременная память — наиболее важная и наиболее сложная из систем памяти. емкость первых названных систем памяти ограничена: первая состоит несколько десятых секунд, вторая — несколько единиц хранения. однако какие-то границы объема долговременной памяти все же существуют, так как мозг является конечным устройством. он состоит из 10 млрд нейронов и каждый способен удерживать существенное количество информации. причем оно настолько велико, что практически можно считать, что емкость памяти человеческого мозга не ограничена. все, что удерживается на протяжении более чем нескольких минут, должно находиться в системе долговременной памяти.

главный источник трудностей, связанных с долговременной памятью, — это проблема поиска информации. количество информации, содержащейся в памяти, велико, и поэтому сопряжено с серьезными трудностями. тем не менее, отыскать необходимое удается быстро.

оперативная память

понятием оперативная память обозначают мнемические процессы, обслуживающие актуальные действия, операции. такая память рассчитана на сохранение информации, с последующим забыванием соответствующей информации. срок хранения такого вида памяти зависит от и может варьироваться от нескольких минут до нескольких дней. когда мы выполняем какое-либо сложное действие, например арифметическое, то осуществляем его по частям, кускам. при этом мы удерживаем “в уме” некоторые промежуточные результаты до тех пор, пока имеем с ними дело. по мере продвижения к конечному результату конкретный “отработанный” материал может забываться.

двигательная память

двигательная память — это запоминание, сохранение и воспроизведение различных движений и их систем. встречаются люди с ярко выраженным преобладанием этого вида памяти над другими ее . один психолог признавался, что он совершенно не в состоянии воспроизвести в памяти музыкальную пьесу, а недавно услышанную оперу может воспроизвести лишь как пантомиму. другие же люди, наоборот, вообще не замечают у себя двигательной памяти. огромное значение этого вида памяти состоит в том, что она служит основой для формирования различных практических и трудовых навыков, равно как и навыков ходьбы, письма и т.д. без памяти на движения мы должны были бы каждый раз учиться осуществлять соответствующие действия. обычно признаком хорошей двигательной памяти является ловкость человека, сноровка в труде, “золотые руки”.

эмоциональная память

эмоциональная память — память на чувства. эмоции всегда сигнализируют о том, как удовлетворяются наши потребности. эмоциональная память имеет весьма важное значение для жизнедеятельности человека. чувства, пережитые и сохраненные в памяти, проявляются в виде сигналов, которые либо к действию, либо удерживают от действия, вызвавшего в прошлом отрицательное переживание. эмпатия — способность сочувствовать, сопереживать другому человеку, герою книги основана на эмоциональной памяти.

образная память

образная память — память на представления, картины природы и жизни, а также на звуки, запахи, вкусы. она бывает зрительной, слуховой, осязательной, обонятельной, вкусовой. если зрительная и слуховая память, как правило, хорошо развиты, и играют ведущую роль в жизненной ориентировке всех нормальных людей, то осязательную, обонятельную и вкусовую память в известном смысле можно назвать профессиональными . как и соответствующие ощущения, эти виды памяти особенно интенсивно развиваются в связи со специфическими условиями деятельности, достигая поразительно высокого уровня в условиях компенсации или замещения недостающих видов памяти, например, у слепых, глухих и т.д.

словесно-логическая память

содержанием словесно-логической память являются наши мысли. мысли не существуют без языка, поэтому память на них и называется не просто логической, а словесно-логической. поскольку мысли могут быть воплощены в различную языковую форму, то воспроизведение их можно ориентировать на передачу либо только основного смысла материала, либо его буквального словесного оформления. если в последнем случае материал вообще не подвергается смысловой обработке, то буквальное заучивание его оказывается уже не логическим, а механическим запоминанием.

объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота