emeli2007
04.02.2022 22:40

Вычислить y= │x-2│ по определению модуля на pascalabc

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Азазин
01.08.2020 02:42

Примечание: я могла не совсем правильно понять смысл фразы «записать условие задачи». Написала, как смогла (см. последний абзац).

Решение.

Программа (то есть, собственно, решение задачи) начинается после слова begin.

Сначала переменной Sum присваивается значение 0 (о чём нам говорит знак :=, что значит «присвоить»; теперь Sum=0).

Затем активируется цикл «for..do». Этот цикл сначала присваивает переменной х (которая записана между for и do) значение 1 (цифра после х и знака :=). После этого цикл увеличивает значение х на единицу, пока она не станет равной 10 (цифра после to). Каждый раз, как х увеличивается на единицу, совершается действие, указанное после «do», а именно «Sum:=Sum + 1» — переменной Sum присваивается значение на единицу большее, чем предыдущее. Другими словами, х, которая сначала равна 1, увеличивается на единицу столько раз, пока не станет равной 10, и каждый раз, как это происходит, Sum тоже увеличивается на 1. Так как изначально Sum=0 (из-за строчки «Sum:=0»), и мы увеличиваем её значение на единицу 10 раз (при х = 1; 2; 3; 4; 5; 6; 7; 8; 9 и 10), то в результате Sum=10.

Строчка «writeln (‘Sum=‘, Sum)» выводит на экран сначала сочетание символов «Sum=», а затем значение переменной Sum (10).

На этом программа заканчивается, о чём свидетельствует строчка End.

Итак, в задаче используются две переменные: Sum — основная переменная, над которой совершаются действия и конечное значение которой в результате выводится на экран; относится к целочисленному типу данных (integer), т. к. в программе принимает только значения нуля и первых десяти натуральных чисел.

х — вс переменная, необходимая для запуска цикла «for... do». Напрямую над ней действия не совершаются. Также имеет целочисленный тип данных, так как принимает только целые значения от 1 до 10.

На основе этого можно записать строчку

var Sum, x: integer;

Условие задачи можно примерно описать так:

Есть некая переменная Sum, равная нулю. Напишите программу, которая 10 раз увеличит её значение на 1, используя только оператор присваивания и цикл «for», а также выведет конечное значение Sum на экран.

0,0(0 оценок)
Ответ:
АминаАлханова
26.02.2021 05:23

Имя Софья (стар. София) в переводе с древнегреческого языка означает «мудрость», «премудрость», «мудрая». Существует вариант перевода «разумность», «наука». На Русь имя Софья пришло вместе с принятием православия.

.

Имя Полина Полина имеет несколько версий происхождения. Первая из них – самая распространённая – имя Полина произошло от имени древнегреческого бога солнца Аполлона и означает «солнечная» или же «посвящённая Аполлону». Существуют варианты перевода «освобождённая» или же «освобождающая». В этом случае, Полина – это одна из форм имени Аполлинария, которое в русском народе получило наибольшее распространение, нежели полное имя, за счёт более красивого и лаконичного звучания, а также из-за лёгкости произношения для русских людей.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота