BerikLord777
05.11.2020 14:17

Напишите программу сложения двух простых дробей (без сокращения дроби). с клавиатуры вводятся значения 4 переменных: числитель и знаменатель первой дроби и числитель и знаменатель второй дроби. на экран выводится 2 числа: числитель полученной дроби и знаменатель.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Anastasiia666
10.10.2020 00:47

Paskal ABC

uses CRT;


var a, b, c, d, e, f:integer;


begin


readln(a, b, c, d);


e:=(d*a)+(c*b);

f:=b*d

writeln(e,' ', f);

end.

0,0(0 оценок)
Ответ:
Thesanek30rusMaps
10.10.2020 00:47

var a,b,c,d:real;

   c1, c2, z1, z2:real;

begin

 write('Введи числитель первой дроби: '); read(a);

 write('Введи знаменатель первой дроби: '); read(b);

 write('Введи числитель второй дроби: '); read(c);

 write('Введи знаменатель второй дроби: '); read(d);

 write(a + ' / ' + b + ' + ' + c + ' / ' + d + ' = ');

 if(b = d) then begin

   c1 := a + c;

   write(c1 + ' / ' + b);

 End else Begin

   z1 := b * d;

   c1 := (z1 / b) * a;

   c2 := (z1 / d) * c;

   z2 := c1 + c2;

   write(z2 + ' / ' + z1);

 end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота