annaerkina
09.06.2022 17:40

Напишите программу, выводящую все простые числа произвольной плследовательности. размер последовательности задает пользователь программы паскаль 7 классрешите

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
JIucenok
10.10.2020 00:47

function isPrime(n: integer): boolean;

var d: integer;

begin

 d := 2;

 while (d <= Round(Sqrt(n))) and (n mod d <> 0) do d += 1;

 isPrime := d > Round(Sqrt(n))

end;

var N, a, i: integer;

begin

 Read(N);

 i := 1;

 while i<=N do

 begin

   Read(a);

   if isPrime(a) then Write(a, ' ');

   inc(i)

 end

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота