5678998765
07.01.2022 14:22

Написать программув массиве а записаны данные о росте игроков баскетбольной команды (в сантиметрах). найти средний рост этих игроков.паскальсount: = 0; sum: = 0; for i: =1 to n do if (180 < a[i]) and (a[i] < 190) then begin count: = count + 1; sum: = sum + a[i] end; write(sum/count);

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
siraevadiana
24.01.2020 04:03
//Pascal
var
  A: array [1..5] of integer;
  min, max, minInd, MaxInd: integer;
  i: byte;
begin
  writeln('Заполнение массива.');
  for i := 1 to 5 do
  begin
    write('А[', i, '] = '); readln(A[i]);
  end;
  writeln;
  Max := A[1]; Min := A[1];
  for i := 1 to 5 do
  begin
  if Max < A[i] then begin Max := A[i]; MaxInd := i; end;
  if Min > A[i] then begin Min := A[i]; MinInd := i; end;
  end;
  writeln('Номер минимального элемента = ', MinInd);
  writeln('Номера минимального и максимального = ', MinInd, ' и ',MaxInd);
end.

1.найти номер минимального элемента массива. 2. найти номера минимального и максимального элементов
0,0(0 оценок)
Ответ:
NamaruC3
24.01.2020 04:03
#include<iostream>

float average(int* a, int first, int last)
{
    int s = 0;
    for(int i = first; i <= last; ++i)
        s += a[i];
    return s * 1. / (last - first + 1);
}
int min_i(int* a, int n)
{
    int m = a[0];
    int numb = 0;
    for(int i = 1; i < n; ++i)
        if(m > a[i])
        {
            m = a[i];
            numb = i;
        }
    return numb;
}
int max_i(int* a, int n)
{
    int m = a[0];
    int numb = 0;
    for(int i = 1; i < n; ++i)
        if(m < a[i])
        {
            m = a[i];
            numb = i;
        }
    return numb;
}
int main()
{
    int N;
    std::cin >> N;
    int X[N];
    for(int i = 0; i < N; ++i)
        std::cin >> X[i];
    std::cout << "Average of whole array: " << average(X, 0, N - 1) << std::endl;
    int first = min_i(X, N);
    int last = max_i(X, N);
    if(first > last)
    {
        int temp = first;
        first = last;
        last = temp;
    }
    if(last - first == 0 || last - first == 1)
        std::cout << "Average of shorter array: " << average(X, 0, N - 1) << std::endl;
    else
    {
        int delta = last - first;
        for(int i = last; i < N; ++i)
            X[i - delta + 1] = X[i];
        std::cout << "Average of shorter array: " << average(X, 0, N - delta) << std::endl;
    }
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота