N1ke1N1kev1ch
19.05.2020 17:19

По информатике написать программу, 20 количество элементов массива больших чем 20(элементов 5: ,массив вводится с клавиатуры )

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Monimix
22.10.2020 17:58

Объяснение:

#include<iostream>

#include<math.h>

using namespace std;

Int main()

{

Double ch,min,sec,ch1,min1,sec1,ch2,min2,sec2,minut;

setlocale (LC_ALL, " rus");

cout<<"Введите время начала разговора ch1, min1, sec1 " << "\n";

cin>>ch>>min>>sec;

Cout<<"Введите врямя конца разговора ch2 ,min2, sec2 "<<"\n";

cin>> ch2>>min2>>sec2;

ch=ch2-ch1;

min=min2-min1;

sec=sec2-sec1;

min=ch*60+min+(sec/60);

minut=min*30;

Cout<<"Стоимость разговора = "<<minut<< " копеек "

return 0;

}

0,0(0 оценок)
Ответ:
Darina2581
10.06.2020 07:19
Воспользуемся расширенной записью шестнадцатиричного числа в десятичной системе счисления. Тогда
3(a*16²+b*16+c)=b*16²+c*16+a;
767a=208b+13c; 59a=16b+c → a=(16b+c)/59  (1)
Здесь a,b,c - шестнадцатиричные цифры, имеющие десятичный эквивалент от 0 до 15.
Наложим ограничения. a и b не могут быть нулевыми, поскольку с них начинаются числа, а с может быть и нулем. При b=15 и c=15 значение a по формуле (1) не может быть больше (16*15+15)/59, что в целых числах дает 4.
Следовательно, нам надо подобрать такие b и c, чтобы a принимало значения от 1 до 4. Будем подставлять эти значения в (1).
1) При а=1 получаем (16b+c)/59=1 → 16b+c=59.
b=59/16=3 (нацело), c=59-16*3=11. Искомое число 13B₁₆
2) При а=2 получаем (16b+c)/59=2 → 16b+c=118.
b=118/16=7 (нацело), с=118-16*7=6. Искомое число 276₁₆

Аналогичным образом находим два остальных числа: 3B1₁₆ и 4EC₁₆

Замечание. Фактически, мы получаем числа 59х1, 59х2, 59х3, 59х4 и переводим их в шестнадцатиричную систему счисления, поскольку в формуле (1) в скобках записано представление расширенное представление шестнадцатиричного числа.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота