Katekate2001lol
20.02.2020 01:38

Составить программу к : сколько шансов при бросании трёх игральных костей выбросить x очков (от 3 до 18) и какие это варианты ( при вложенный циклов). pascal abc

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Ivanlabur
10.10.2020 00:33

var pk,vk,tk,x,k:integer;

begin

write('x = ');

readln(x);

for pk:= 1 to 6 do

begin

for vk:=1 to 6 do

begin

for tk:=1 to 6 do  

if pk+vk+tk=x then

begin

writeln('pk = ',pk,'   vk = ',vk,'   tk = ',tk,'   ',pk,' + ',vk,' + ',tk,' = ',pk+vk+tk);

k:=k+1

end

end

end;

writeln(k,' шансов')

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота