zulka123
26.05.2021 14:17

Для исполнения чертежник составьте программу рисования слова рама ,для изображения букв используйте алгоритм

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Незнайка2015все
22.01.2022 07:25

Так как изначально в задании указано : "на любом известном вам языке программирования" - вот, держи на С.

#include <stdio.h>

#include <stdlib.h>

#include <locale.h>

#define N 100

int main()

{

setlocale(LC_ALL, "Rus");

int i, M;

float B[N], MIN;

printf(" Введите количество элементов массива (не больше 100) => ");

scanf("%d", &M);

if (M < 100)

{

for (i = 0; i < M; i++)

{

printf("Введите [%d] элемент массива =>", i);

scanf("%f", &B[i]);

}

for (i = 0; i < M; i++)

printf("%1.0f ", B[i]);

MIN=B[0];

for (int i=1; i<M; i++)

{

if (B[i]<MIN)

MIN=B[i];

}

printf ("\n\tМинимальное значение в массиве => %7.2f", MIN);

}

else

printf("Ошибка. Заданное число элементов массива слишком большое.");

return 0;

}

0,0(0 оценок)
Ответ:
лера2127
08.01.2022 22:09

Гипотетически под адресацию можно использовать 56 - 8 = 48 бит. После этого возникают одни вопросы. Если мы адресуем байтами, то объем будет 2^48 байт и это 256 терабайт. Однако можно адресовать и 48 битными "словами" (в случае, если мы приводим размер слова к максимальному размеру операнда, что не является строго необходимым), тогда это 1536 терабайт. Можно использовать и более экзотические адресации или обработки. Например загружать "страницы" и адресовать данные внутри них, тогда объем будет вплоть до 2^(48+48) байт.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота