НикитаТим
19.01.2020 20:09

Составьте программу, моделирующую игру(угодай число),так чтобы задуманное число x отыскивалось как корень уравнения (4x+8)x+4=rez

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kazakstanarmy
05.11.2021 07:06
Думаю музыка для ушей это аналоговый сигнал.
Аудиальный кортекс головного мозга музыканта воспринимает от ушей этот аналоговый стгнал (музыку) и его головной мозг переводит этот аналоговый сигнал в цифровой, ноты. У музыканта,в мозге есть АЦП, аналого-цифровой преобразователь, он слышит каждую ноту и сравнивает с эталоном по частоте, беря эталоны из своей памяти.
Потому что у него хороший музыкальный слух. Память знает, что частота ноты Ля  второй октавы 440 герц. Поток звука он сравнивает с эталонными нотами и записывает сами ноты. Я сумбурно объяснил?
0,0(0 оценок)
Ответ:
kkkkkdashakkkk
16.03.2023 23:21

[any] Pascal: (без хранения введённых чисел => "эффективная")

var a, i, x: integer; begin  for i := 1 to 6 do  begin    read(a);    if a>0 then x := x + 1    else if a<0 then x := x - 1  end;  if x>0 then write('Больше положительных')  else if x<0 then write('Больше отрицательных')  else write('Одинаково')end.

PascalABC.NET: (с хранением введённых чисел в массиве)

## var a := ReadArrInteger(6); var x := a.Sum(x -> x>0 ? 1 : -1); if x=0 then Write('Одинаково') else Print('Больше', x>0 ? 'положительных' : 'отрицательных')

Пример работы:


Паскаль. 8 класс. даны 6 чисел. каких чисел больше - положительных или отрицательных? !
Паскаль. 8 класс. даны 6 чисел. каких чисел больше - положительных или отрицательных? !
Паскаль. 8 класс. даны 6 чисел. каких чисел больше - положительных или отрицательных? !
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота