ainur0018Ainur
21.10.2021 20:04

Вариант 3. на¬пишите программу, которая в последовательности натуральных чисел определяет минимальное чётное число. программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется чётное число. программа должна вывести одно число — минимальное чётное число

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
tbzhi
10.10.2020 00:21

С++ / gcc 7.3.0


#include <iostream>

#include <algorithm>

#include <vector>

int main()

{

   unsigned int N;

   std::cin >> N;

   std::vector<unsigned int> v(N);


   for(unsigned int i = 0; i < N; i++)

       std::cin >> v[i];


   std::sort(v.begin(), v.end());

   for(auto it : v)

   {

       if(it % 2 == 0)

           std::cout << it << std::endl;

       break;

   }

   return 0;

}



Вариант 3. на¬пишите программу, которая в последовательности натуральных чисел определяет минимально
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота