1836294
06.02.2021 13:44

20 ! требуется написать программу, вычисляющую значение какой-либо функции (у )= х^2-5 , если х< 3 ≤ х ≤ 7 ; или (у) = х , если х = 0; (у)= х - 3 , если х > 7 ;

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
хорошист55007
15.06.2022 07:37
Program test;
var a,b,c,d,e,f,g,h,j,k,l,s: integer;
begin
s:=0;
writeln ('Тест "Приятно ли с вами общаться?" Если человек общителен, то это еще не значит, что с ним приятно разговаривать. Есть люди, которые своей общительностью надоедают каждому буквально с первых минут разговора. Посмотрите внимательно, разве мало вокруг таких людей? А вы приятный собеседник?');
writeln ('1) Вы любите больше слушать, чем говорить?');
writeln ('1 да, 2 нет');
readln (a);
if a=1 then s:=s+1 else s:=s+0;
writeln ('2) Вы всегда можете найти тему для разговора, даже с незнакомым человеком?');
writeln ('1 да, 2 нет');
readln (b);
if b=1 then s:=s+1 else s:=s+0;
writeln ('3) Вы всегда внимательно слушаете собеседника? ');
writeln ('1 да, 2 нет');
readln (c);
if c=1 then s:=s+1 then s:=s+0;
writeln ('4) Любите ли вы давать советы?');
writeln ('1 да, 2 нет');
readln (d);
if d=1 then s:=s+1 else s:=s+0;
writeln ('5) Если тема разговора вам не интересна, станете ли показывать это собеседнику?');
writeln ('1 да, 2 нет');
readln (e);
if e=1 then s:=s+1 else s:=s+0;
writeln ('6) Раздражаетесь, когда вас не слушают?');
writeln ('1 да, 2 нет');
readln (f);
if f=1 then s:=s+1 else s:=s+0;
writeln ('7) У вас есть собственное мнение по любому вопросу?');
writeln ('1 да, 2 нет');
readln (g);
if g=1 then s:=s+1 else s:=s+0;
writeln ('8) Если тема разговора вам не знакома, станете ли вы ее развивать?');
writeln ('1 да, 2 нет');
readln (h);
if g=h then s:=s+1 else s:=s+0;
writeln ('9) Вы любите быть центром внимания?');
writeln ('1 да, 2 нет');
readln (j);
if j=1 then s:=s+1 else s:=s+0;
writeln ('10) Есть ли хотя бы три предмета, по которым вы обладаете достаточно прочными знаниями?');
writeln ('1 да, 2 нет');
readln (k);
if k=1 then s:=s+1 else s:=s+0;
writeln ('11) Вы хороший оратор?');
writeln ('1 да, 2 нет');
readln (l);
if l=1 then s:=s+1 else s:=s+0;
writeln ('Ваши - ', s);
writeln ('1- : Трудно сказать, то ли вы молчун, из которого не вытянешь ни слова, то ли настолько общительны, что вас стараются избегать, но факт остается фактом: общаться с вами далеко не всегда приятно, а порой даже тяжело. Вам бы следовало над этим задуматься. 4- : Вы, может быть, и не слишком общительный человек, но почти всегда внимательный и приятный собеседник. Вы можете быть и весьма рассеянным, когда не в духе, но не требуете от окружающих в такие минуты особого внимания к вашей персоне.10- : Вы, наверное, один из самых приятных собеседников, друзья не могут без вас обойтись');
end.
0,0(0 оценок)
Ответ:
тупойученик129
12.01.2021 22:59

print('--- 1 ---')

b = float(input('Введите b: '))

a = b**3/9-6.4*(b+8)+3*b/4

print('a =', a)

print()

print('--- 2 ---')

a = float(input('Введите a: '))

b = float(input('Введите b: '))

d = a**3*b/7-2*a*b**2*(a+b)

print('d =', d)

print()

print('--- 3 ---')

a = float(input('Введите a: '))

b = float(input('Введите b: '))

q = (3*a**3-2*a*b+b**2)/(2*a*(3*a-b))

print('q =', q)

print()

print('--- 4 ---')

x = float(input('Введите x: '))

y = float(input('Введите y: '))

k = x**3-4*x*y*(x+y**2)

print('k =', k)

print()

print('--- 5 ---')

v = float(input('Введите v: '))

h = abs(v+1.7)*(2*v+3)

print('h =', h)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота