Brainsetup
07.02.2022 07:00

Написать фрагмент программы вычесляюших чисел сумы 2 чисел если слоганмые водятся в первое и второе поля а сума отображается в 5 поле

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
SizovMarina
24.01.2021 07:22
Чтобы было удобнее, располагаем перед собой алфавит:


и действуем по указанному правилу:
берём букву из слова и по алфавиту смотрим, какая буква идёт третьей после нашей буквы
если упёрлись в конец алфавита- продолжаем счёт с начала алфавита (движемся по кругу)
чтобы это было удобнее, я запишу алфавит сразу с добавленными буквами в его конце:


такое действие выполняем для каждой буквы в слове

Итак, шифруем слова:
ИНФОРМАЦИЯ => ЛРЧСУПГЩЛВ
КОМПЬЮТЕР => НСПТБХЗУ
ЧЕЛОВЕК => ЪЗОСЕЗН

А вообще, для человека такое преобразование не очень удобно делать, поэтому для большего объёма текста проще было бы составить программу, или таблицу в Экселе, которая бы выполняла нужные действия с текстом.
0,0(0 оценок)
Ответ:
несамаяумная
20.12.2022 18:20
Var
  x,y:integer;
  vcp,dx,dy:real;
begin
  Write('Возраст Тани='); Read(x);
  Write('Возраст Мити='); Read(y);
  vcp:=(x+y)/2;
  dx:=x-vcp; dy:=y-vcp;
  Writeln('Средний возраст равен ',vcp);
  if dx>0 then begin
    Writeln('Таня старше среднего возраста на ',dx,' лет,');
    Writeln('а Митя младше среднего возраста на ',-dy,' лет.')
  end
  else
    if dx=0 then Writeln('Таня и Митя ровесники')
    else begin
      Writeln('Таня младше среднего возраста на ',-dx,' лет,');
      Writeln('а Митя старше среднего возраста на ',dy,' лет.')
    end
end.

Тестовое решение:
Возраст Тани=15
Возраст Мити=12
Средний возраст равен 13.5
Таня старше среднего возраста на 1.5 лет,
а Митя младше среднего возраста на 1.5 лет.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота