Demo180
15.09.2021 14:37

1. написать программу по нахождению максимального элемента массива; 2. написать программу по нахождению отрицательных, положительных и нулевых элементов массива

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
GansikT
09.10.2020 23:44

Program maximal;

const

nmax=100;

var

a:array[1..nmax] of integer;

N,i,max:integer;

begin

readln(N);

max:=0;

for i:=1 to N do

 begin

   read(a[i]);

   if max<a[i] then

     max:=a[i];

end;

write(max);

end.



2) Program B;

    const

nmax=100;

var

a:array[1..nmax] of integer;

N,i,z:integer;

begin

readln(N);

z:=0;

for i:=1 to N do

 begin

   read(a[i]);

   if a[i]>0 then

       write(a[i],' ');

    if a[i]=0 then

       z:=z+1;

end;

writeln();

for i:=1 to N do

   begin

      if a[i]<0 then

        write(a[i],' ');

  end;

writeln();

for i:=1 to z do

   write('0',' ')

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота