Лаймик0
09.03.2020 04:14

Дано натуральное число.напишите программу,которая проверяет, является ли оно четырехзначным и расположены ли его цифры в порядке убывания.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
leo00000
09.10.2020 23:19

var

 n, i: Integer;

 s: string;

 isu: Boolean;

begin

 Write ('Введите число: ');

 Read (n);

 if (n >= 1000) and (n <= 9999) then

   WriteLn ('Это число четырехзначное')

 else

   WriteLn ('Это число не четырехзначное');

 s := IntToStr (n);

 isu := True;

 for i := 1 to Length (s) - 1 do begin

   if s [i] <= s [i + 1] then begin

     isu := False;

     Break;

   end;

 end;

 WriteLn;

 if Isu then

   WriteLn ('Цифры расположены в порядке убывания')

 else

   WriteLn ('Цифры НЕ расположены в порядке убывания');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота