123451415
03.02.2022 04:15

Составить программу, которая подсчитывает сумму элементов массива, больших 50 и меньших или равных 80.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
катя4003
09.10.2020 23:15

var

 A: array [1..10] of Integer;

 i, s: Integer;

begin

 Randomize;

 WriteLn ('Массив:');

 for i := Low (A) to High (A) do begin

   A [i] := Random (100);

   Write (A [i], ' ');

 end;

 for i := Low (A) to High (A) do begin

   if (A [i] > 50) and (A [i] <= 80) then

     s := s + A [i];

 end;

 WriteLn;

 WriteLn ('Сумма элементов массива = ', s);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота