mordvichev92
24.08.2022 20:23

1(в тетради для дз) написать программу, обрабатывающую поток водимых с клавиатуры целых чисел (пока не будет введен 0) и выводящую на экран количество введенных чисел, количество положительных, а также сумму и среднее арифметическое только положительных. можно решать через любой оператор цикла (кроме for). формат вывода: введено чисел_ из них положительных_ сумма положительных чисел_ среднее арифметическое положительных чисел_

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Frosterion
09.10.2020 23:01

var a,k,p,s: integer;

begin  

repeat

write('Введите число: ');

readln(a);

if a<>0 then k:=k+1;

if a>0 then

begin

p:=p+1;

s:=s+a

end

until a=0;

writeln;

writeln ('Введено чисел_',k);

writeln ('Из них положительных_',p);

writeln ('Сумма положительных чисел_',s);

writeln ('Среднее арифметическое положительных чисел_',s/p:0:3);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота