Мальчик123870
21.05.2022 13:30

Составить программу на алгоритмическом языке нахождения большего из трёх чисел

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
oksana1382
08.11.2022 05:24

Привет всему 12 "А" классу(Реальному).Я знаю, зачем вы тут, и я вам Вы знаете меня, как Anxel09.

var a,b,sum,i : integer;  

begin

 readln(a,b);

 if (a < 0) or (a > 10) then

   while (a < 0) or (a > 10) do begin

       writeln('Число ''a'' не подходит: ');

   readln(a);

   end;

 if (b < 0) or ( b > 10) then

       while (a < 0) or (a > 10) do begin

   

       writeln('Число ''b'' не подходит: ');

   readln(b);

   end;

sum := 1;

   

 for i:= 1 to b do

   sum:= sum * a;

 writeln('Число ''а'' в степени ''b''',' = ', sum );

 

end.

Вот и все!

Объяснение:

0,0(0 оценок)
Ответ:
Hvhvhvhvhvhv23
26.05.2021 23:19
Код: 1) program Mas; var i,ne,ch,n:integer; a:array [1..1000] of integer; begin read(n); randomize; for i:=1 to n do begin a[i]:=random(80)+21;write(a[i],' ');//Распечатка массива, увидешь правильно ли программа выполняет функци                         end; for i:=1 to n do begin if a[i] mod 2=0 then ch:=ch+1 else ne:=ne+1; end;writeln; writeln('Нечетные=',Ne); writeln('Четные=',Ch); end. 2)const n = 10; var A: array [ 1 .. n ] of integer; i, znachenie, count: integer; sred_arifm, sum: real; begin for i:=1 to n do begin write('a[,'i,']=');readln(a[i]); end; write('Введите значение:');readln(znachenie); sum:=0;count:=0; for i:=1 to n do if a[i] > znachenie then begin inc(count); sum:=sum+a[i]; end; sred_arifm:=sum/count; write('Среднее арифметическое ... =',sred_arifm:3:2); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота