VTKOF
09.08.2022 15:29

Кто знает информатику? напишите программу для рисования квадрата в цыкле)заранее !

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kulaevmasya
29.07.2021 20:37
Var
   i,j,k,p:integer;
   a:array[1..8,1..8]of integer;
begin
writeln('Исходный массив:');
for i:=1 to 8 do
begin 
for j:=1 to 8 do
    begin   
    a[i,j]:=random(20);
    write(a[i,j]:3)
    end;
    writeln
end;
for i:= 1 to 8 do
     for j:= 1 to 8 do
     for k:= 1 to 8 do
        begin
        if i mod 2=0 then
           begin
           if (a[i,j]<a[i,k]) then
              begin
              p:=a[i,j];
              a[i,j] := a[i,k];
              a[i,k] := p
              end
           end
           else
              if a[i,j] > a[i,k] then
                 begin
                 p:=a[i,j];
                 a[i,j] := a[i,k];
                 a[i,k] := p
                 end
       end;
writeln('Преобразованный массив:');
for i:=1 to 8 do
   begin
   for j:=1 to 8 do
      write(a[i,j]:3);
   writeln
   end;
end.
0,0(0 оценок)
Ответ:
nadyashapeeva
16.08.2021 05:35

#include<bits/stdc++.h>

using namespace std;

int main()

{int n;

cin>>n;

int a[n+2];

a[1]=n*n-n+1;

for (int i=2;i<=n;i++)

a[i]=a[i-1]+2;

cout<<n<<"^3  = ";

for (int i=1;i<=n;i++)

{cout<<a[i];

if (i<n+1)

cout<<" + ";

}

}

##я понял твою последовательность я понял формулу через

## n. если ты заметишь в каждой последовательности N членов : для    ## одного двух трех и т.д.   a1=n^2-n+1  через арифметическую последовательность  a1   an=a1+2(n-1);  их сумма же равна n*n*n мы находим аналогично все члены прогрессии

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота