уукуку
17.06.2022 02:02

Составить программу и блок схему на листе. для : ,,найдите наибольшее из 3 чисел а,в,с"

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Славик14102
12.08.2022 18:21

Program N198453627;
uses crt;
var
  n,i:integer;
  max,v:real;
  yes: string;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  max:=0;
  yes:='NO';
  writeln('Введите количество машин (не больше 30 - у меня мало памяти!)');
  write('N = ');
  readln(n);
  if n>30 then
      writeln('Это слишком много!')
    else
      begin
        writeln('Вводите зарегистрированную скорость каждого автомобиля');
        for i:=1 to n do
          begin
            write(i,'-й автомобиль: ');
            readln (v);
            if v >300 then
                begin
                  writeln ('По-моему, твои приборы плохо отрегулированы - так быстро машины не ездят!');
                  writeln ('Это число не будет учтено');
                end
              else
               if v < 1  then
                begin
                  writeln ('Ты точно умеешь измерять скорость автомобиля? Скорость не может быть меньше 1!');
                  writeln ('Это число не будет учтено');
                end
              else
                begin  
                  if v<30 then yes:='YES';
                  if v>max then max:=v;
                end;
          end;
        writeln();
        writeln('Максимальная зарегистрированная скорость: ',max);
        writeln('Cкорость меньше 30 км/ч? ',yes);
      end;
end.

0,0(0 оценок)
Ответ:
Lilit66696
29.05.2022 05:13

Паскаль АВС:

 

Program Maxtv;
uses crt;
const n=10;
var
  a:array[1..n] of real;
  r: real;
  i:integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  writeln();
  writeln('Введите R, не равное 0'); readln(r);
  if r<>0 then
    begin
      writeln('Элементы массива:');
      randomize;
        for i:=1 to n do
          begin
            a[i]:=random(100)-50;
            write (a[i]:7:2);
          end;
        writeln();
        writeln('Заменяем 2,4,5,9:');
        a[2]:=a[2]/r;
        a[4]:=a[4]/r;
        a[5]:=a[5]/r;
        a[9]:=a[9]/r;
        for i:=1 to n do
          write (a[i]:7:2)
    end
  else
    writeln('Ну вас же просили не вводить 0!');    
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота