katemur6969
06.07.2020 20:11

Написать программу (полностью) для нахождения произведение суммы нечетных цифр и их минимума в четырехзначном числе. программа должна начинаться следующим образом и не содержать иных переменных кроме данных. var min, digit, s, n, res : integer; begin readln(n); входные данные: четырехзначное число. выходные данные: результат

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
уже3
17.08.2020 08:28

... - уже данный код в условии

s := 0;

min := 10;

for res := 1 to 4 do

begin

digit := n mod 10;

if (digit mod 2 = 1) then

begin

s += digit;

if (digit < min) then

min := digit;

end;

n := n div 10;

end;

writeln(s * min);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота