akimova5
20.01.2021 00:54

Можете написать программу на паскале для чилел 117 и 19. заранее

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
alenazakhar2000al
29.04.2020 17:38

//Поскольку вы не указали структуру файла и язык программирования, то подберу их сам.

//ЯП: C#

//Структура: рост/имя/вес/страна проживания

Код:

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.IO;

namespace Prog

{

class Program

{

static void Main(string[] args)

{

string location = "C://Test//Persons.txt";

try

{

int size = File.ReadLines(location).Count();

if (size > 0)

{

List<string> person = new List<string>();

string[] tallestPerson = new string[4];

int maxHeight = -1;

int height = 0;

int index = 0;

StreamReader PersonsReader = new StreamReader(location, Encoding.Default);

for (int i = 0; i < size; i++)

{

person.Add(PersonsReader.ReadLine());

height = Convert.ToInt32(person[i].Remove(person[i].IndexOf("/")));

if (height > maxHeight)

{

maxHeight = height;

index = i;

}

}

string tmp = person[index];

int paramIndex = 0;

for (int j = 0; j < tmp.Length; j++)

{

if (tmp[j] != '/')

tallestPerson[paramIndex] += tmp[j];

else

paramIndex++;

}

Console.WriteLine("Самый высокий человек: " + tallestPerson[1]);

Console.WriteLine("Рост: " + tallestPerson[0] + " см");

Console.WriteLine("Вес: " + tallestPerson[2] + " кг");

Console.WriteLine("Страна проживания: " + tallestPerson[3]);

}

else

{

Console.WriteLine("Файл пустой!");

}

}

catch (Exception)

{

Console.WriteLine("Ошибка! Файл не нейден, либо нарушена его структура!");

}

finally

{

Console.ReadKey();

}

}

}

}


Написать программу, которая в файле находит самого высокого человека и выводит его данные.
Написать программу, которая в файле находит самого высокого человека и выводит его данные.
Написать программу, которая в файле находит самого высокого человека и выводит его данные.
Написать программу, которая в файле находит самого высокого человека и выводит его данные.
Написать программу, которая в файле находит самого высокого человека и выводит его данные.
0,0(0 оценок)
Ответ:
МарияЛобачева
05.12.2022 10:15

Воспользуемся самым простым при таблицы триад и тетрад.
Для начала разобъем справа-налево на разряды по четыре цифры:
10|1011.

Так как нам не хватает две цифры, то в начало добавим два незначащих нуля:
0010|1011.

Так как нам известны разряды, то обратимся к таблице тетрад.
Видим, что коду "0010" соответствует цифра "2", а к "1011" соответствует буква "B".

Итого наш ответ: "2B".

Можно и другим перевести в десятичную систему счисления.

Пронумеруем справа-налево цифры, начиная с нуля.
Переведем в десятичную систему счисления.

1*2^5 + 0*2^4 + 1*2^3 + 0*2^2 + 1*2^1 + 1*2^0 = 32 + 8 + 2 + 1 = 43.

Для перевода в шестнадцатиричную систему счисления делим полученный ответ на "16" столбиком.

Решение смотри во вложении.


Перевести шестнадцатеричное число 101011(2) в шестнадцатеричную систему счисления
Перевести шестнадцатеричное число 101011(2) в шестнадцатеричную систему счисления
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота