Яяяячканр345
12.01.2020 04:05

Определить все простые делители числа, введенного с клавиатуры pascal abc

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Lesa222
06.10.2020 13:56
Задача на динамическое программирование. Советую почитать поподробнее на эту тему в интернете. Подобные задачи для изучения: платная лестница, кузнечик, последовательность Фибоначчи.
#include <iostream>
#include <cmath>
using namespace std;
int main()  {
   int n;   
   cin >> n;   
   int height[n];   
   for(int i=0; i<n; i++)       
      cin >> height[i];    
   int energy[n];   
   for(int i=1; i<n; i++)
   energy[i] = energy[i-1] + abs(height[i]-height[i-1]);
   cout << height[n-1];
   return 0;
}
0,0(0 оценок)
Ответ:
kosmikanna
10.04.2021 04:55

#include <iostream>

#include <cmath>

using namespace std;


double Otr(double Ax, double Bx, double Ay, double By) {

return sqrt((Bx - Ax)*(Bx - Ax) + (By - Ay)*(By - Ay));

}


int main() {

double Ax, Ay, Bx, By, Cx, Cy, Dx, Dy;

cin >> Ax >> Ay >> Bx >> By >> Cx >> Cy >> Dx >> Dy;

cout << "|AB|=" << Otr(Ax, Bx, Ay, By) << endl;

cout << "|AC|=" << Otr(Ax, Cx, Ay, Cy) << endl;

cout << "|AD|=" << Otr(Ax, Dx, Ay, Dy) << endl;

return 0;

}


Написать программу в с++ описать функцию otr(ax,bx,ay,by) вещественного типа находящую длину отрезка
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота